How to include extenal website in nodogsplash captive portal

8
3



Please subscribe for more useful videos about FREE Internet and WiFi Marketing –~–
How to include extenal website in nodogsplash captive portal and redirect user with RedirectURL
You have install FREE WiFi Marketing solution, and now you want to change your splash file or redirect your clients to another website
In this video FREE WiFi Marketing will guide you how to customized your captive portal
You need to connect to your router using SCP, in this sample we use WinSCP to connect with File protocol SCP.
Login with username/password
Your splash file is located in /etc/nodogsplash/htdocs/splash.html
Here is where you include your website with iframe
This is the button where your client click to accept the Internet access
You can also include Google Analytics code to track how many customer are accessing your captive portal
You can store banner and button on the router if you donot want to load from website
To change other options such as RedirectURL or ClientForceTimeout, edit nodogsplash.conf under /etc/nodosplash
Thank you for watching, please like us as for more useful videos
Please subscribe and find how to do #WiFiMarketing DIY Wi-Fi router long range antenna, RAM, flash and turn on social WiFi marketing with OpenWrt captive portal to boost your business using wireless LAN

High gain 9 dBi dual band wifi antenna VS original TP-LINK routers

WiFi antenna hack 5dBi to 16dBi long range outdoor TP-Link router

Display wirelessly to TV using AnyCast M2 Plus Mini Wi-Fi Display Dongle Receiver

Out door long range WiFi router mod Tp-Link TL-WR841N hack lightning protection

Copy eprom flash chip to chip without computer ezp2010 copy tools

#WiFiRouter #AntennaWiFi #DIYWiFi #OpenWRT #WirelessLAN

Nguồn: https://royboxofficecollections.com/

Xem thêm bài viết khác: https://royboxofficecollections.com/giai-tri/

8 COMMENTS

  1. nodosplash running but not working. I config nodosplash.conf (RedirectURL ). When i connect to wifi i just have connect and no any redirect!!! Which config value i need to config??

  2. HI. good video but im stucked. My webpage dosnt come up with the iframes tags… is just empty and everything seems well coded. Any suggestion?? tnx

  3. bạn cho mình hỏi chút. mình làm iframe như bạn hướng dẫn nhưng khi dùng truy cập trong iframe lại hiển thị giống trang flash trứ không hiển thị trang đích. bạn hướng dẫn mình mới.
    mình đã cấu hình thêm FirewallRuleSet preauthenticated-users {
    FirewallRule allow tcp port 80 to 192.168.1.1
    FirewallRule allow tcp port 80 to "trang đích .com"
    nhưng vẫn không dc

  4. In my install it's all working just fine, but I can't see what is in the iframe, Do I have to allow the address in somewhere?

  5. no logro hacer que me redireccione a la pagina de bienvenida.
    Mi configuracion es la sgte :
    En un router TP-Link TL-WR1043N/ND v3 con OpenWrt Designated Driver 49934 / LuCI Master (git-16.266.66957-07591d7), Nodogsplash nodogsplash_0.9_beta9.9.8-2_ar71xx .
    La configuracion de mis archivos son los sgtes.
    * etc/network/interfaces

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config globals 'globals'
    option ula_prefix 'fda6:f4cf:2a83::/48'

    config interface 'lan'
    option type 'bridge'
    option ifname 'eth1'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

    config interface 'wan'
    option ifname 'eth0'
    option proto 'dhcp'

    config interface 'wan6'
    option ifname 'eth0'
    option proto 'dhcpv6'

    config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

    config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '1 2 3 4 0'

    config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '5 6'

    #ESTA ES LA INTERFACE NUEVA

    config interface 'wifi2'
    option proto 'static'
    option ipaddr '192.168.5.1'
    option netmask '255.255.255.0'
    option _orig_ifname 'eth1'
    option _orig_bridge 'false'

    * dhcp

    config dnsmasq
    option domainneeded '1'
    option boguspriv '1'
    option filterwin2k '0'
    option localise_queries '1'
    option rebind_protection '1'
    option rebind_localhost '1'
    option local '/lan/'
    option domain 'lan'
    option expandhosts '1'
    option nonegcache '0'
    option authoritative '1'
    option readethers '1'
    option leasefile '/tmp/dhcp.leases'
    option resolvfile '/tmp/resolv.conf.auto'
    option localservice '1'

    config dhcp 'lan'
    option interface 'lan'
    option start '100'
    option limit '150'
    option leasetime '12h'
    option dhcpv6 'server'
    option ra 'server'

    config dhcp 'wan'
    option interface 'wan'
    option ignore '1'

    config odhcpd 'odhcpd'
    option maindhcp '0'
    option leasefile '/tmp/hosts/odhcpd'
    option leasetrigger '/usr/sbin/odhcpd-update'

    config dhcp 'wifi2'
    option start '100'
    option leasetime '12h'
    option limit '150'
    option interface 'wifi2'

    *WIRELESS

    config wifi-device 'radio0'
    option type 'mac80211'
    option channel '11'
    option hwmode '11g'
    option path 'platform/qca955x_wmac'
    option htmode 'HT20'

    config wifi-iface
    option device 'radio0'
    option network 'wifi2'
    option mode 'ap'
    option ssid 'OpenWrt'
    option encryption 'none'

    CONGIURACION DEL ETC/NODOGSPLASH/NODOGSPLASH.CONF
    Esta todo por defecto lo unico que cambie es la linea del GatewayInterface probe con br-lan , eth1 eth0 wlan wl0 y nada ……….
    #
    # Nodogsplash Configuration File
    #

    # Parameter: GatewayInterface
    # Default: NONE
    #
    # GatewayInterface is not autodetected, has no default, and must be set here.
    # Set GatewayInterface to the interface on your router
    # that is to be managed by Nodogsplash.
    # Typically br0 for the wired and wireless lan on OpenWrt White Russian.
    # May be br-lan on OpenWrt Kamikaze.
    #
    GatewayInterface br-lan

    ya no se que mas hacer para que me redireccione.

    Espero alguien sepa … saludos.

LEAVE A REPLY

Please enter your comment!
Please enter your name here